[angr] Angr: recent version does not work

Fish Wang fish.thss at gmail.com
Fri Oct 7 10:56:22 PDT 2016


I can confirm that it is an issue (unicorn is not on PyPI). We will work on
it later today. Sorry for that.

Best,
Fish

-----Original Message-----
From: angr [mailto:angr-bounces at lists.cs.ucsb.edu] On Behalf Of PH
Sent: Friday, October 7, 2016 10:46 AM
To: angr at lists.cs.ucsb.edu
Subject: [angr] Angr: recent version does not work

Hi guys,

I tried to update to the most recent version of angr with "pip install
--upgrade angr" and it fails with

either

  Could not find a version that satisfies the requirement unicorn (from
simuvex->angr) (from versions: )
No matching distribution found for unicorn (from simuvex->angr)

(on my debian machine)

or

Building sim_unicorn
    error: [Errno 2] No such file or directory: 'simuvex_c'

(on my ubuntu machine).


Also after deleting angr I can no longer install a fresh version.

Please give me a hint how to solve this.

Thanks.

P.

_______________________________________________
angr mailing list
angr at lists.cs.ucsb.edu
https://lists.cs.ucsb.edu/mailman/listinfo/angr



More information about the angr mailing list